Wednesday, April 6, 2016

HiPi Modules 0.49 Released

Change log

 - Re-factored Build.PL so there are no sudo calls or package installations in there. Moved all that to hipi-install script which now prompts for confirmation before installing any packages.

- Removed suid scripts hipi-i2c and hipi-pud as they  are obsolete since introduction of raspi-gpio and update of i2c device driver in Rasbian distribution.

The installation of packages in the Build.PL script of the distribution was vexing some folks severely. I've removed it so hopefully all can sleep well. They did after all have a point.

All necessary dependency checking is now done in the separate auto installation script - hipi-install - which also now prompts the user for confirmation before installing any package dependencies or pre-built binaries (Wx distribution ).